Benutzer-Werkzeuge

Webseiten-Werkzeuge


ag:infrastruktur:nbsp:netz

Das Netz des nbsp ist Teil des dn42. Alle Rechner im Netzwerk sind aus diesem erreichbar. Desweiteren sind alle Rechner via IPv6 aus dem Internet erreichbar!

Eine Übersicht der Hosts im nbsp findest du auf hosts.

Technische Daten

WLAN ESSID: nbsp
IPv6 fd20:bdda:5df0::/64 (dn42)
2a01:170:1112::/64 (öffentlich vom /48)
RA IPv6 Präfixe werden per RA announced
IPv4 172.23.208.0/24 82.139.255.240/29
DHCP 172.23.208.[100…254]
ASN 76129

Prefix fuer ARM Farm: 2a01:170:1112:4242::/64

Feste IPs

IPv6

IP Host
PREFIX::1 fritz.nobreakspace.org
PREFIX::2 kamino.nobreakspace.org
PREFIX::4 monitor.nobreakspace.org
PREFIX::5 padlock.nobreakspace.org
PREFIX::c icebox.nobreakspace.org
PREFIX::f arm farm head node
PREFIX::10 pxe.nobreakspace.org
PREFIX::fe router.nobreakspace.org

IPv4

die öffentlichen v4 werden zusätzlich als Hostroute auf die Hosts gelegt.

IP Host ggf. öffentliche v4
172.23.208.1 fritz.nobreakspace.org 82.139.255.240
172.23.208.2 kamino.nobreakspace.org
172.23.208.3 beamer.nobreakspace.org
172.23.208.4 monitor.nobreakspace.org 82.139.255.241
172.23.208.5 padlock.nobreakspace.org 82.139.255.242
172.23.208.6 switch
172.23.208.7 modem
172.23.208.8 fritzbox
172.23.208.9 drucker HL-3040
172.23.208.10 unicorn/eth0
172.23.208.11 unicorn/eth1
172.23.208.12 icebox
172.23.208.13 klingel
172.23.208.14 troll nur intern
172.23.208.15 arm farm pi 82.139.255.243
172.23.208.16 pxe.nobreakspace.org 82.139.255.244
172.23.208.254 router.nobreakspace.org 82.139.197.228 (ppp)

Netzwerkdosen

Alle Netzwerkdosen im nbsp sind angeschlossen. Die jeweils linken Buchsen sind mit 1GBit belegt, die rechten nur mit 100MBit. Einige der linken Dosen sind mit speziellen VLANs belegt (siehe Tabelle der Switchconfig). Die Portnummer am Switch entspricht jeweils der Dosennummer.

Die rechten Buchsen der Dosen 1 und 17 funktionierten bei einem Test nicht. Möglicherweise ist der 100MBit-Switch defekt.

Switchconfig

VLANs

Name Tag Function
Default 1 nbsp
mesh 2 mesh
dsl 7 dsl

Portconfig

(alle nicht erwähnten: Default untagged)

u → untagged, t → tagged

Port VLANs
2 mesh/u
13 mesh/u
16 mesh/u
21 mesh/u
22 mesh/t, nbsp/t, dsl/t
23 nbsp/u, dsl/t

Portbelegung

Port Verwendung
1..20 linke Buchsen im nbsp
21 Mesh Buddenbrookhaus
22 Server
23 DSL-Modem
24 100MBit Switch

VLANs konfigurieren

  show ports
  configure vlan "Default" delete ports 5
  configure vlan "mesh" add ports 5 untagged 
  show ports
  save

Firewallregeln

-A FORWARD ! -s 172.23.208.0/23 -d 172.23.208.3/32 -j REJECT

IPv6

Es handelt sich dabei um einen SixXS Tunnel, der in Hamburg terminiert wird.

Peerings

Der nbsp peert mit dem dn42 und somit auch mit dem Freifunk ICVPN.

dn42 WHOIS

person:             Chaotikum e.V.
contact:            mailto:intern@chaotikum.org
nic-hdl:            CHAOTIKUM-DN42
aut-num:            AS76129
org:                CHAOTIKUM-DN42
as-name:            CHAOTIKUM-AS
descr:              Chaotikum e.V. AS
admin-c:            CHAOTIKUM-DN42
tech-c:             CHAOTIKUM-DN42

Aktive Peerings

Zur Zeit existieren zwei Peerings: burgtor und holstentor (über Freifunk)

Es werden sowohl IPv6 als auch IPv4 Routen ausgetauscht.

DNS

fritz ist auch DNS Server. Zusätzlich zu den ICANN Domains werden derzeit folgende TLDs aufgelöst:

  • dn42.
  • ffhl.
  • hack.
  • ffki.
  • ffa.
  • ffc.

nbsp.dn42.

Außerdem verwaltet fritz die TLD nbsp.dn42. Dort könnt ihr auch eigene Hosts eintragen.

WLAN Knoten mit nbsp Client und mesh

wireless

  config wifi-iface 'nbsp_client'  
          option network 'nbsp'  
          option device 'radio0'
          option mode 'ap'
          option ssid 'nbsp'                
          option encryption psk2            
          option key **HIERWASSINNVOLLESEINTRAGEN!!**
                               
  config wifi-iface 'nbsp_mesh'       
          option network nbsp               
          option mode mesh                  
          option device radio0              
          option mesh_id nbsp               

network

  config interface 'nbsp'
          option ifname 'wan lan1 lan2 lan3 lan4'
          option proto 'dhcpv6'
          option type 'bridge'
          option igmp_snooping '0'
          option peerdns '1'
ag/infrastruktur/nbsp/netz.txt · Zuletzt geändert: 21.01.2017 11:48 von Matthias Schiffer